Mac系统xcode-select --install不能下载该软件的解决办法

2024-01-23 11:04:22 作者:欧亿体育

xcode-select --install不能下载该软件的解决办法


xcrun: error: invalid active developer path (/Library/Developer/CommandLineT

更新mac os后无法运行git,gcc等命令,出现missing xcrun错误.

这是因为更新系统后会卸载xcode,重新安装后会缺失xcode的命令行工具(command line tools),所以导致部分工具无法在终端运行。解决方法为运行以下命令:

xcode-select --install

并下载xcode命令行工具即可。 --->并不行。

“xcode-select --install不能下载该软件,因为目前bai不可在du软件服务器上使用它……”,这是由于zhixcode的命令行工dao具无法安装不能安装该软件 因为当前无法从软件更新服务器获得的错误。

相信很多人在使用Mac的时候也跟我一样碰到过跟我一样的问题“xcode-select --install不能下载该软件,因为目前不可在软件服务器上使用它……”,这是由于xcode的命令行工具无法安装不能安装该软件 因为当前无法从软件更新服务器获得的错误。

具体报错内容如下:

1

2

3

4

5

6

7

8

9

Error: The following formula:git

cannot be installed as a binary package and must be built from source.

Install the Command Line Tools:xcode-select --install

Error: Git must be installed and in your PATH!

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools),

missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Error: The following formula:python

cannot be installed as a binary package and must be built from source.

Install the Command Line Tools:xcode-select --install

在线咨询 拨打电话

电话

010-67916526

微信二维码

微信二维码